Anasayfa » Linux'ta VPN Güvenlik Açığı Bulundu

Makaleyi Paylaş

Haberler

Linux'ta VPN Güvenlik Açığı Bulundu

Güvenlik araştırmacıları, potansiyel saldırganların * NIX cihazlarındaki VPN bağlantılarını ele geçirmesine ve IPv4 ve IPv6 TCP akışlarına isteğe bağlı veri yükleri yüklemesine izin veren yeni bir güvenlik açığı buldular.

Dağıtım ve Linux çekirdek güvenlik ekibinin yanı sıra Systemd, Google, Apple, OpenVPN ve WireGuard gibi etkilenen diğer kişilere dağıtım yapmak için CVE-2019-14899 olarak izlenen güvenlik açığını açıkladılar.

Güvenlik açığının, FreeBSD, OpenBSD, macOS, iOS ve Android dahil olmak üzere çoğu Linux dağıtımını ve Unix benzeri işletim sistemlerini etkilediği bilinmektedir.

Şu anda eksik olan işletim sistemlerinin ve birlikte geldikleri sistemlerinin bir listesi;

Sponsor

• Ubuntu 19.10 (systemd)
• Fedora (systemd)
• Debian 10.2 (systemd)
• Arch 2019.05 (systemd)
• Manjaro 18.1.1 (systemd)
• Devuan (sysV init)
• MX Linux 19 (Mepis+antiX)
• Void Linux (runit)
• Slackware 14.2 (rc.d)
• Deepin (rc.d)
• FreeBSD (rc.d)
• OpenBSD (rc.d)

Güvenlik açığı ağa bağlı bir saldırganın başka bir kullanıcının bir VPN’ye bağlı olup olmadığını, VPN sunucusu tarafından bağlı oldukları IP adresini ve belirli bir web sitesine etkin bir bağlantı olup olmadığını belirlemesini sağlamaktadır.

Araştırmacılar “Ek olarak, şifreli paketleri sayarak ve / veya boyutlarını inceleyerek kesin sıra ve numaralarını belirleyebiliyoruz,ve bu durumun TCP akışına veri enjekte edilmesine ve bağlantıları ele geçirilmesine izin veriyor” diye ekledi.

Araştırmacılar, test ettikleri Linux dağıtımlarının çoğunun bu açığı kullanan sistemlerin saldırılara karşı savunmasız olduğunu keşfetti. Ayrıca, 28 Kasım 2018’den sonra yayımlanan ve Stride modundan Loose moduna geçiş yapan Ters Yol filtresi ile gelen sistem sürümlerini kullanan tüm dağıtımların savunmasız olduğunu belirttiler.

Kaynak

Link

Makaleyi Paylaş

Cevap bırakın