Cevap : Load balanc...
 
Bildirimler
Hepsini Temizle

Cevap : Load balance nasıl yaparım**4506 backbone de trafık yonlendırme yapamıyorum  

  RSS
Fatih KARAALIOGLU
(@fatihkaraalioglu)
Kıdemli Üye

Merhaba oncelikle aramiza hosgediniz.Gelelim sorulariniza yanit aramaya.Load balance sorunuzla baslayalim.Simdi siz diyorsunuz ki her iki hattimda aktif olarak calissin ve yuk paylasimi yapsin.Mantikli bir yontem.Simdi bunun gerceklesmesi icin neler gerekli ona bakalim.Oncelikle her iki hattinizda bir ISP den geliyorsa load balance yapmak cok daha kolaylasir.Her iki hattinizda telekomdan geliyorsa o zamn isler biraz zorlasir.Oncelikle bir konfigurasyon ornegiyle baslayalim.Eger her iki hattiniz da Bir Isp nin ayni pop noktasindaki routerden size geliyorsa var olan interfaceler altinda ‘ip load-sharing per-packet’ komutunu calistirmaniz gerekli.Bu islemin Isp terafinda da size gelen her iki interface de uygulanmasi lazim.Bunun disinda Isp tarafindan size tahsis edilmis bir reel ip blogu ver ise Isp kendi tarafinda bu blogu her iki interfade route etmek durumundadir ( herhangi bi metrik girmemeli) sizde default route olarak her iki interfaceside yazmalisiniz komut satirina.Asagidaki ornekle bakalim.Koyu olarak belirttigim noktelar onemli.
Not:Kullanilan ip ler ornek olsun diye yazilmistir sizde kullanilanlarin  reel ip oldugunu dusunerek uygulama yapilmisir.

Cisco 1841

 interface FastEthernet0/0
 description Firewall
ip address 192.168.10.1 255.255.255.0
 speed auto
 full-duplex
!
interface Serial0/0/0
 description Internet_A
 ip address 172.16.10.2 255.255.255.252
ip load-sharing per-packet
 encapsulation ppp
 no fair-queue
!
interface Serial0/1/0
 description Internet_B
 ip address 172.16.11.2 255.255.255.252
ip load-sharing per-packet
 encapsulation ppp
 no fair-queue

ip route 0.0.0.0 0.0.0.0 Serial0/0/0
ip route 0.0.0.0 0.0.0.0 Serial0/1/0


ISP

interface Serial0/0/0
ip address 172.16.10.1 255.255.255.252
ip load-sharing per-packet
 encapsulation ppp
 no fair-queue
!
interface Serial0/1/0
ip address 172.16.11.1 255.255.255.252
ip load-sharing per-packet
 encapsulation ppp
 no fair-queue

ip route 192.168.10.0 255.255.255.0 Serial0/0/0
ip route 192.168.10.0 255.255.255.0 Serial0/1/0

Simdi hizmeti ISP den degilde telekomdan aldiginizi dusunursek yapilacak islemler burada biraz karisiyor.Turk Telekom backbone da Juniper ve Alcatel marka routerler kullaniyor dolayisiyla hatlarin load balance calismasi icin oncelikle Telekom tarafinda hattiniz hangi cihaza gidiyorsa ‘ip load-sharing per-packet’ komutunun o cihazdaki karsiligini bilmek gerekir.
Boyle bir durumda yapilacak en iyi cozum route-map tir fakat o zaman bile gercek anlamda bir load balance yapmis olamayiz.Route map ile bir kisim protokelleri hatlar arasinda paylastirabiliriz fakat bunun sonucunda hattin biri full dolu iken digeri bos olabilir.Dlayisiyla tam anlamiyla bir cozum olmayacaktir.

Gelelim ikinci sorunuzun yanitini aramaya.Bu sorunuzun en guzel cozum yontemi route map yazmaktir.gshdsl hattan nete cikacak olan networkleri belirleyip daha sonra bir Access list olusturup route map ile paketleri yonlendirebiliriz.Bunun icinde ornek bir uygulama yapmaya calisalim.Diyelimki vlan 10 a ait uyeler 192.168.1.100 ip li firewalldan nete cikacaklar dger vlanlara ait uyeler ise 192.168.1.200 ip li frewall uzerinden nete cikacaklar Buna gore konfigurasyon asagidaki gibi olmalidir.

ORNEK:

interface Vlan10
 description PERSONEL
 ip address 192.168.1.1 255.255.255.0
!
interface Vlan20
 description xx
 ip address 192.168.2.1 255.255.252.0
 ip policy route-map yonlendir
!
interface Vlan30
 description yyyyy
ip address 192.168.3.1 255.255.255.0
 ip policy route-map yonlendir
!
interface Vlan40
 description zzzzz
 ip address 192.168.4.1 255.255.255.0
!
interface Vlan50
 description vvvvv
 ip address 192.168.5.1 255.255.255.0
 ip policy route-map yonlendir
!
interface Vlan60
 description cnmc
 ip address 192.168.6.1 255.255.255.0
  ip policy route-map yonlendir
!
ip route 0.0.0.0 0.0.0.0 192.168.1.100
access-list 10 permit ip 192.168.1.0 0.0.0.255 any
access-list 105 permit tcp 192.168.2.0 0.0.0.255 any eq www
access-list 105 permit tcp 192.168.2.0 0.0.0.255 any eq 443
access-list 105 permit tcp 192.168.2.0 0.0.0.255 any eq smtp
access-list 105 permit tcp 192.168.2.0 0.0.0.255 any eq pop3
access-list 105 permit tcp 192.168.2.0 0.0.0.255 any eq 1863
access-list 105 permit tcp 192.168.2.0 0.0.0.255 any eq 5190
access-list 105 permit tcp 192.168.3.0 0.0.0.255 any eq www
access-list 105 permit tcp 192.168.3.0 0.0.0.255 any eq 443
access-list 105 permit tcp 192.168.3.0 0.0.0.255 any eq smtp
access-list 105 permit tcp 192.168.3.0 0.0.0.255 any eq pop3
access-list 105 permit tcp 192.168.3.0 0.0.0.255 any eq 1863
access-list 105 permit tcp 192.168.3.0 0.0.0.255 any eq 5190
access-list 105 permit tcp 192.168.4.0 0.0.0.255 any eq www
access-list 105 permit tcp 192.168.4.0 0.0.0.255 any eq 443
access-list 105 permit tcp 192.168.4.0 0.0.0.255 any eq smtp
access-list 105 permit tcp 192.168.4.0 0.0.0.255 any eq pop3
access-list 105 permit tcp 192.168.4.0 0.0.0.255 any eq 5190
access-list 105 permit tcp 192.168.4.0 0.0.0.255 any eq 1863
access-list 105 permit tcp 192.168.5.0 0.0.0.255 any eq www
access-list 105 permit tcp 192.168.5.0 0.0.0.255 any eq 443
access-list 105 permit tcp 192.168.5.0 0.0.0.255 any eq smtp
access-list 105 permit tcp 192.168.5.0 0.0.0.255 any eq pop3
access-list 105 permit tcp 192.168.5.0 0.0.0.255 any eq 5190
access-list 105 permit tcp 192.168.5.0 0.0.0.255 any eq 1863
access-list 105 permit tcp 192.168.6.0 0.0.0.255 any eq www
access-list 105 permit tcp 192.168.6.0 0.0.0.255 any eq 443
access-list 105 permit tcp 192.168.6.0 0.0.0.255 any eq smtp
access-list 105 permit tcp 192.168.6.0 0.0.0.255 any eq pop3
access-list 105 permit tcp 192.168.6.0 0.0.0.255 any eq 5190
access-list 105 permit tcp 192.168.6.0 0.0.0.255 any eq 1863
access-list 105 permit ip 192.168.2.0 0.0.0.255 any
access-list 105 permit ip 192.168.3.0 0.0.0.255 any
access-list 105 permit ip 192.168.4.0 0.0.0.255 any
access-list 105 permit ip 192.168.5.0 0.0.0.255 any
access-list 105 permit ip 192.168.6.0 0.0.0.255 any
!
route-map yonlendir permit 10
 match ip address 105
 set ip default next-hop 192.168.1.200

Bu sekilde cok kullanilan protikolleri diger vlanlardan gelen tum paketleri dg.shdsl e yonlendirmis olduk.Firewall tarafinda gerekli izinler verilmis ise internet cikisi sorunsuz bir sekilde calisacaktir.

Selamlar.

Alıntı
Gönderildi : 24/02/2008 17:07
Paylaş: