ÇözümPark'a hoş geldiniz. Oturum Aç | Üye Ol
 
Ana Sayfa Makale Video Forum Resimler Dosyalar Etkinlik Hizmetlerimiz Biz Kimiz

Hewlett-Packard

IRF (Intelligent Resilient Framework) ve LACP (Bridge Aggregation) Konfigürasyonu

HP Network ürün ailesi içerisinde yer alan “A” serisi network ürünlerinde ön plana çıkan Aktif /Aktif mimariyi temsil eden “IRF” protokolü ve network dünyasında fiziksel ve mantıksal port, link yedekliğini sağlayan en çok ihtiyaç duyulan konfigürasyonlardan biri olan “LACP” protokolü hakkında bilgi vererek, switchler üzerinde uygulamalı olarak anlatacağım.

 

 

 

IRF Nedir ?

 

IRF protokolü A serisi HP network ürünleri üzerinde aktif edilebilen, network mimarisinde donanım ve konfigürasyon anlamında n+1 mimarisini temsil eden “redundancy” protokolüdür.

 

IRF mimarisi hangi switch modelleri üzerinde yapılabilir ?  Kaç adet switch’e kadar yapılabilir? Sorularınızın cevabını aşağıda yer alan imaj’dan alabilirsiniz.

 

clip_image002

 

IRF yapabilmek için gereksinimler;

Minumum 2 Adet IRF desteği olan switch

Her iki switch üzerinde en az 2 adet 10 Gigabit interface port

2 Adet switch’i IRF yaparken kullanmak üzere mutlaka DAC (Direct Attach Cable) kablo kullanmak zorundasınız. DAC kablo her iki ucunda da SFP+ (10G) bağlantıyı taşıyabilecek çeşitli metrajlarda olan kablolardır. Ayrıca sipariş edilmelidir. Network ürünleri için DAC kablolar ayrı olarak kullanılır. Server veya Storage için kullanılanlar çoğu zaman network ürünleri ile uyumsuzdur.

 

IRF Mimarisinde 2 farklı network bağlantısı mevcut

 

clip_image004

 

 

IRF kullanılan yapılarda, Switch seçimliğinde Master ve Slave olmak üzere switch rolleri mevcuttur. İki Adet switch’den sonra birden çok Slave switch yapı içerisinde konumlandırılabilir.

 

Network bağlantısı işlemi en son yapılandırılır. DAC kablo kullanımında en önemli konu kabloların çapraz portlara bağlanması gerekliliğidir. Yukarıdaki resim bunu simgelemektedir.

 

Örneğin; SW-A ve SW-B iki adet switch’iniz mevcut;

 

SW-A üzerinde yer alan İnterface ten-gigabit  1/0/25 numaralı porta takılı olan kablonun öteki ucunu, SW-B üzerinde yer alan interface ten-gigabit  1/0/26 numaralı porta takmalısınız.

 

SW-A üzerinde yer alan İnterface ten-gigabit 1/0/26 numaralı porta takılı olan kablonun öteki ucunu, SW-B üzerinde yer alan interface ten-gigabit  1/0/25 numaralı porta takarak, 2 Adet switch için IRF kablolama yapısını oluşturmuş olursunuz. (Çok Önemlidir !!!! )

 

IRF topoloji üzerinde Master ve Slave switch seçimliliği neye göre yapılır?

Mevcut’da priority numaraları “1” olarak gelir. Eğer varsayılan olarak bırakılırsa switch üzerindeki ilgili portların  MAC adreslerine bakılır.

Master switch seçiminde 1-32 arasında değer verilebilir. En yüksek değere sahip olan switch master switch ilan edilir.

Varsayılan olarak IRF domain üyesi olan switch’ler içerisinde bir çok değer aynı ve herhangi bir tane cihazın “shutdown” olması durumundaki olası senaryoda en uzun süredir sistem durumu bakımından “up” olan switch master ünvanını alır.

Priority değerlerinin switchlerde aynı olması durumunda en düşük MAC adresine sahip olan switch Master ünvanını alır.

Yukarıda yazılı olan değerler switch sayısı arttığı takdirde Slave -1, Slave 2 seçimliliğinde de aynı şekilde devam etmektedir.

 

IRF Konfigürasyon Adımları

İlk olarak cihazlar üzerinde member-id ve priority değerlerine müdahale etmek gerekmektedir.

irf member member-id priority 32   , bu komut ile ,member-id değeri switch üzerinde 1 nolu switch’I temsil eder.  Switch üzerinde interface 1/0/1 kırmızı ile işaretli olan “1” değeri switch’in irf domain’i içerisinde ki “1” nolu switch olduğunu tarif eder.

Priority değeri 1-32 aralığında  switch üzerinde master veya slave olduğunu tanımlamak içindir. En yüksek rakamsal değere sahip olan switch “Master” olur.

irf member current-member-id renumber new-member-id  bu komut ile, yukarıda tanımlamasını yaptığımız interface durumuna göre, slave olacak switch member numarasını master haricindekileri, irf member numarasını şu an ki durumu numarası ve değiştirilmesi istenen id numarası girilir.

interface ten-gigabit port-id    (irf domaini içerisinde kullanılacak port numarasının yazılması lazım)

shutdown (irf üyesi olabilmesi için ilgili portun shutdown durumda olması gereklidir.)

irf-port 1/1  (1 nolu irf üyesinin  1 nolu portu fiziksel portu kullanılacak, 1/2  1 nolu üyenin 2 nolu portu kullanılacağı anlamına gelir)

port group interface ten-gigabit port-id    (port-id kısmına 1/0/25 ve /26 ayrı ayrı yazılarak eklenir.)

interface ten-gigabit port-id   (Daha evvel kapatılmış olan ilgili interface’ler içerisine girilerek yönetimsel olarak yeniden açılır.)

undo shutdown

save (komutu ile yapılan tüm konfigürasyon kaydedilmelidir.)

Genel IRF konfigürasyonu esnasında kullanılacak tüm komutların temel mantığı yukarıda anlatıldığı gibidir.

Topolojimiz üzerinde 2 Adet HP-A5800 Switch IRF yapılandırmasında kullanılacak. Omurga olarak yapı üzerinde kullanacağımız bu ürüne kenar switch olarak “LACP” konfigürasyonu ile HP-A5120 EI switch bağlayarak topoloji üzerinde, fiziksel aktif/aktfi omurga yedekliliğini kenar switch üzerinde de aktif/aktif link yedekliliğini sağlayarak SPOF olarak bilinen. (Single point of failure) kuralını yerine getirmiş olacağız.

 

LACP Nedir?

Link Aggregation Control Protocol network mimarisi üzerinde kenar/dağıtım/omurga katmanındaki aktif kullanılan network ekipmanları ve sunucular için, switch’ler arasında bağlantıda port başına link yedekliliğini sağlamak için kullanılan protokoldür. IEEE 802 1ad  olarak standart olarak yer almıştır.

Mantıksal olarak switch üzerinde, en az 2 adet port bulundurulması zorunludur.

Switch’ler üzerinde port’ların bant genişlikleri aynı olma zorunluluğu yoktur. Fakat farklı hızlara sahip olan portlarda çoğunlukla yapılması pek tavsiye edilmez.

LACP konfigürasyonu bir çok switch üzerinde, 4 adet fiziksel port kullanılarak yapılabilir. Switch başına ürün marka modeline göre 8 porta veya 16 porta kadar çıktığı durumlar mevcuttur.

LACP protokolü bir “load balance” protokolü değildir. Link yedekliliğini sağlamak için kullanılan bir protokoldür.

Link üzerindeki veri aktarım yoğunluğu ilk “up” olan port üzerindedir. Diğer “up” olan portlarda sırası ile bu veri yoğunluğu rastgele switch tarafından dağıtılmaktadır.

Aşağıda temsili olarak mantıksal görüntü switch ve sunucu için ayrı ayrı yer almaktadır.

clip_image006

HP Network ürünlerinde A serisi cihazlarda 2 tip LACP metodu vardır. Statik ve Dinamik LACP’dir.

Statik LACP protokolü aktif edildiğinde switchler arasında herhangi bir protocol bilgisi taşınmamaktadır.

Dinamik LACP protokolü aktif edildiğinde switch’lerde karşılıklı olarak “BPDU” paketlerinin taşınmasına izin verilmektedir.

IRF içerisinde kullanılan komponentleri, detaylarını ve LACP hakkında aktarılan bilgilerin ardından switch’ler üzerinde IRF ve LACP konfigürasyonunu gerçekleştirebiliriz.

 

 

 

IRF ve LACP Konfigürasyonu

Aşağıda mevcut olan topolojideki bağlantılar referans alınarak konfigürasyon gerçekleştirilecektir. Mantıksal görseli de aşağıdaki gibi takip etmekte fayda var.

 

clip_image008

Topoloji üzerindeki cihazların tamamında VLAN-1 ip adreslerinin tanımlanmış olması gerekmektedir.

Ardından IRF konfigürasyonu yapacağımız switchler üzerinde çalışmaya başlayabiliriz. “Master”  switch olarak belirlemek istediğimiz switch üzerinde yapılan konfigürasyon adımları aşağıdaki gibidir.

 

<Switch_A1>system-view

 

[Switch_A1] stp enable   (LACP yapılmadan ve kablolar takılmadan evvel mutlaka kontrol edilmelidir.)

 

[Switch_A1]sysname Switch_A1

 

[Switch_A1]irf member 1 priority 32

 

[Switch_A1]int ten 1/0/25

 

[Switch_A1-int-ten1/0/25]shutdown

 

[Switch_A1-int-ten1/0/25]quit

 

[Switch_A1]int ten 1/0/26

 

[Switch_A1-int-ten1/0/26]shutdown

 

[Switch_A1-int-ten1/0/26]quit

 

[Switch_A1]irf-port 1/1

 

[Switch_A1-irf-port1/1]port group int ten 1/0/25

 

[Switch_A1]irf-port 1/2

 

[Switch_A1-irf-port1/2]port group int ten 1/0/26

 

[Switch_A1-irf-port1/2]quit

 

[Switch_A1]int ten 1/0/25

 

[Switch_A1-int-ten1/0/25]undo shutdown

 

[Switch_A1-int-ten1/0/25]quit

 

[Switch_A1]int ten 1/0/26

 

[Switch_A1-int-ten1/0/26]undo shutdown

 

[Switch_A1-int-ten1/0/26]quit               

 

[Switch_A1] irf-port-configuration active  (yazılması özellikle şasi switchlerde çok önemli)

 

[Switch_A1]save

 

[Switch_A1]quit

 

 

Slave olarak yapılandıracağımız switch üzerinde yapılması gereken ayarlar ise aşağıdaki gibidir;

 

<Switch_A2>system-view

 

[Switch_A2] stp enable (LACP yapılmadan ve kablolar takılmadan evvel mutlaka kontrol edilmelidir.)

 

[Switch_A2]sysname Switch_A2

 

[Switch_A2] irf member 1 renumber 2

 

[Switch_A2]irf member 1 priority 31

 

[Switch_A2]save

 

[Switch_A2]reboot ( cihaz açıldıktan sonra bir sonraki işlem adımı takip edilmelidir.

 

[Switch_A2]int ten 2/0/25

 

[Switch_A2-int-ten2/0/25]shutdown

 

[Switch_A2-int-ten2/0/25]quit

 

[Switch_A2]int ten 2/0/26

 

[Switch_A2-int-ten2/0/26]shutdown

 

[Switch_A2-int-ten2/0/26]quit

 

[Switch_A2]irf-port 2/1

 

[Switch_A2-irf-port2/1]port group int ten 2/0/25

 

[Switch_A2]irf-port 2/2

 

[Switch_A2-irf-port2/2]port group int ten 2/0/26

 

[Switch_A2-irf-port2/2]quit

 

[Switch_A2]int ten 2/0/25

 

[Switch_A2-int-ten2/0/25]undo shutdown

 

[Switch_A2-int-ten2/0/25]quit

 

[Switch_A2]int ten 2/0/26

 

[Switch_A2-int-ten2/0/26]undo shutdown

 

[Switch_A2-int-ten2/0/26]quit               

 

[Switch_A2] irf-port-configuration active  (yazılması özellikle şasi switchlerde çok önemli)

 

[Switch_A2]save

 

[Switch_A2]quit

Yukarıdaki konfigürasyonun tamamlanmasının ardından DAC kablolardan herhangi bir tanesi ÇAPRAZ olarak master ile slave switch üzerindeki portlara takılır.

SW-A1-İnt ten gig 1/0/25  to  SW-A2 -int ten gig 2/0/26 gibi. DAC kablo takılmasının ardından Slave olan switch otomatik olarak rebott edilecektir. Ortalama 4-5 dk sürecektir bu süreç, Master olan switch üzerindeki tüm konfigürasyonları almak için ve auto-recovery fonksiyonunu aktif etmek için gerçekleştirilir.

Slave switch açıldıktan sonra ikinci port’da takılabilir. SW-A1-İnt ten gig 1/0/26  to  SW-A2 -int ten gig 2/0/25 gibi.

 

Son olarak aşağıdaki komutlar koşturularak IRF topology durumu, port durumu ve port mapping görüntülenerek irf domainin kurulduğu görüntülenir.

 

<Switch_A2>display irf

 

<Switch_A2>display irf configuration

 

<Switch_A2>display irf topology

IRF konfigürasyonun tanımlanmasının ardından, IRF domainine üye olan switchler ve kenar switchler üzerinde Link yedekliliği ve Kenar switchlerde SPOF (Single Point of Failure) durumunu ortadan kaldırmak için LACP (A serisinde Bridge Aggregation) konfigürasyonu yapılmalıdır.

LACP Konfigürasyonu;

IRF domain üyesi olan her iki omurga switch üzerinde de yapılan tüm konfigürasyonlar ortak tutulduğu için yalnızca “Master” olan switch üzerinde aşağıdaki komutları uygulamak yeterlidir.

 

[Switch_A1]int bridge-aggregation 1

 

[Switch_A1-int-bragg1]quit

 

[Switch_A1]int gig 1/0/1

 

[Switch_A1-int-g1/0/1]port link-aggregation group 1

 

[Switch_A1-int-g1/0/1]quit

 

[Switch_A1]int gig 2/0/1

 

[Switch_A1-int-g2/0/1]port link-aggregation group 1

 

[Switch_A1-int-g2/0/1]quit

 

[Switch_A1]int bridge-aggregation 1

 

[Switch_A1-int-bragg1] port link-type trunk

 

[Switch_A1-int-bragg1] port trunk permit vlan all   (all yerine sadece omurga switch ile paylaşılması veya görüşülmesi istenen vlanları tanımlayabilirsiniz. Vlan 1 3  5 7 gibi )

Kenar Switch üzerindeki LACP konfigürasyonu aşağıdaki gibidir;

 

<Switch_B>system-view

 

[Switch_B] stp enable   (LACP yapılmadan ve kablolar takılmadan evvel mutlaka kontrol edilmelidir.)

 

[Switch_B]int bridge-aggregation 2

 

[Switch_B-int-bragg2]quit

 

[Switch_B]int gig 1/0/23

 

[Switch_B-int-g1/0/23]port link-aggregation group 2

 

[Switch_B-int-g1/0/23]quit

 

[Switch_B]int gig 1/0/24

 

[Switch_B-int-g1/0/24]port link-aggregation group 2

 

[Switch_B-int-g1/0/24]quit

 

[Switch_B]int bridge-aggregation 2

 

[Switch_B-int-bragg1] port link-type trunk

 

[Switch_B-int-bragg1] port trunk permit vlan all    (all yerine vlan ID’leri ayrı ayrı yazılabilir)

Not: Uplink portları kenar switch’den Omurga’ya 1 adet port bağlayarak önce “up” olması beklenir. Link oturduktan sonra ikinci link takılır.

İşlem Adımları tamamlandıktan sonra,

 

[Switch]display link-aggregation summary

 

[Switch]display link-aggregation verbose

 

[Switch]display interface bridgeaggregaton brief

Komutları kullanılarak işlemlerin sonucunda çıkan tabloda LACP tanımlamalarının başarılı olup olmadıklarını veya link durumları görüntülenerek troubleshoot yapılabilir.

LACP protokolü sayesinde, Layer 2 seviyesinde link yedekliliği, IRF protokolü ile omurga veya dağıtım katmanında switch/konfigürasyon/protokol yedekliliğini sağlamış bulunmaktayız.

 

Yorumlar

 

Evren Banger

Eline Sağlık Gökhan.

Eylül 22, 2013 23:09
 

Rıza ŞAHAN

Elinize sağlık.

Eylül 22, 2013 23:11
 

Hakan UZUNER

Eline sağlık Gökhan Hocam

Eylül 22, 2013 23:58
 

Bilgehan POYRAZ

Elinize sağlık.

Eylül 23, 2013 00:27
 

Ersin CAN

Eline Saglik Gokhan

Eylül 23, 2013 13:15
 

Mehmet PARLAKYİĞİT

Elinize sağlık.

Eylül 24, 2013 09:13
 

Ugur DEMIR

Eline sağlık

Eylül 29, 2013 14:10
 

Eser DOĞAN

elinize sağlık çok güzel bir anlatım olmuş.teşekkürler..

Aralık 12, 2013 11:21
Kimliksiz yorumlar seçilemez kılınmış durumdadır.
 

Bu Kategori

Hızlı aktarma

Etiketler